с решением на python3 У каждого жителя на планете Бинариус есть своя электронная тетрадь. В нее записываются будущие дела по мере их поступления. Записи в этой тетради не всегда идут в нужном порядке. Из-за этого кто-то из жителей может пропустить какое-нибудь важное событие.
Вам даны записи из одной такой тетради. Напишите программу, которая отсортирует записанные в ней события в хронологическом порядке.
Планета Бинариус надеется на вас.
Входные данные
Первая строка содержит одно целое число n (1≤n≤10000) — количество записей в тетради.
Далее следует n строк с описанием событий. Каждое описание включает время, дату события и краткую информацию о событии.
Время события имеет формат «hh:mm», где hh (0≤hh≤23) — часы, mm (0≤mm≤59) — минуты события.
Дата события имеет формат «DD.MM.», где DD (1≤DD≤30) — день, MM (1≤MM≤12) — месяц, (2021≤≤9999) — год события. Дата и время каждого события являются уникальными.
Часы, минуты, день и месяц события в своей записи всегда имеют два знака.
В данной задаче подразумевается, что в одной минуте 60 секунд, в одном часу 60 минут, а один день состоит из 24 часов. Также на планете Бинариус всегда 12 месяцев в году, а каждый месяц состоит ровно из 30 дней.
Информация о событии представляет собой непустую строку, состоящую из символов верхнего и нижнего регистров, пробелов, запятых и точек. Длина строки не превышает 100 символов.
Выходные данные
Выведите информацию о событиях в хронологическом порядке.
Пример
входные данные
3
12:59 05.12.2024 Throw out the trash
20:40 01.05.2024 To go shopping.
12:13 12.06.2023 Pass the unified state exam,
выходные данные
Pass the unified state exam,
To go shopping.
Throw out the trash
a,b,d,K,kp:integer;
P:boolean;
Begin
kp:=0;
ReadLn(a,b);
if (a = 1)or(a = 2) then
Begin
kp:=2;
Write(2,' ',3)
end
else if a = 3 then
Begin
kp:=1;
Write(3);
End;
if a < 5 then a:=5
else if a mod 2 = 0 then a:=a+1;
While a<=b do
Begin
K:=Trunc(Sqrt(A));
d:=3;
P:=true;
While d <= K do
Begin
if A mod d = 0 then P:=false;
d:=d+2
End;
if P then
Begin
kp:=kp+1;
Write(' ',a);
End;
a:=a+2
End;
if kp = 0 then Write(0)
End.
var i, sqrtn, delta: Word;
begin
if (n >= 5) and ((n - 1) mod 6 = 0) or ((n + 1) mod 6 = 0) then begin
i := 5;
delta := 2;
sqrtn := Trunc(sqrt(n));
IsPrime := False;
while i <= sqrtn do begin
if n mod i = 0 then Exit;
Inc(i, delta);
delta := delta xor 6; {смена шага, то 2, то 4}
end;
IsPrime := True;
end else
IsPrime := (n = 2) or (n = 3);
end;
Var A,B,i : Integer;
Begin
Readln(A,B);
For i:=A to B do If IsPrime(i) then Writeln(i);
end.