В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
logpol40
logpol40
03.08.2022 18:24 •  Информатика

С++ Удаление элемента
Удалите из массива элемент в индексом k. Обратите внимание, считывание и вывод массива уже написаны за вас, необходимо написать только фрагмент программы — само удаление элемента.

Входные данные

В первой строке задано натруальное число n (n≤100) и индекс k (0≤k
#include
using namespace std;
int main()
{
int n, k;
cin >> n >> k;
vector A(n);
for (int i = 0; i < A.size(); i++) {
cin >> A[i];
}

for (int i = 0; i < A.size(); ++i){
cout << A[i] << " ";
}
cout << endl;
return 0;
}

между строками кода надо дописать код

Показать ответ
Ответ:
yliana121
yliana121
15.09.2020 20:38
Алгоритм на условном языке.

m:=0.  "количество отрицателных"
p:=0    "количество положительных"
i:=1.
пока i<>0 повторять
    i:=прочитать число, введенное с клавиатуры.
    если i>0 то p:=p+1.
    если i<0 то m:=m+1.
конец цикла пока.
вывести на экран('процент положительных = ', p/(p+m)).
вывести на экран('процент отрицательных = ', m/(p+m)).

Алгоритм будет верно работать, если введено хотя бы одно число, отличное от нуля. В противном случае возникнет ошибка деления на ноль. В нормальных программах подобные случаи отлавливаются и корректно обрабатываются.
0,0(0 оценок)
Ответ:
kristinamilobog
kristinamilobog
29.10.2022 21:34
1.клавиатура,мышь,сканер.микрофон
2.процессор
3.чтение книги,толковый словарь,заучения правила(нащет видеокассеты зависит какое видео)
4.Backspace
5.Рабочий стол
6.операционная система
7.На ПЗУ (не знаю что это постояная память или жесткий диск
8.происходит обработка, связанная с изменением формы информации, но не изменяющая ее содержания
9.Название приложения,кнопка "Свернуть,кнопка "Закрыть",панель инструментов, палітра,рабочая область
10.Жесткий диск,флешка,лазерный диск (для DVD) ,SD-карты
11.Квадрат зелённый
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота