В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
vugarjalilovp0ci9p
vugarjalilovp0ci9p
25.05.2020 01:44 •  Информатика

с заданием составить алгоритм и написать программу для следующих задач, Python→turtle​


с заданием составить алгоритм и написать программу для следующих задач, Python→turtle​

Показать ответ
Ответ:
Vlad584q
Vlad584q
09.05.2020 04:33
{$APPTYPE CONSOLE}
Const
   N = 13;
Var
   A:array[1..N] of real;
   i,C:integer;
Procedure ZAPOLNENIERND();
Var i,j:integer;
Begin
Randomize;
For i:= 1 to N do
    A[i]:=random*21-10;
End;

Procedure BbIBOD();
Var i,j:integer;
Begin
For i:= 1 to n do
    Write(A[i]:4:1,' ');
WriteLn;
End;

Procedure RE();
Begin
Write('i = ');ReadLn(i);
Write('A[',i,'] = ');ReadLn(A[i]);
End;

Procedure SF();
Var
   i:integer;
   S:real;
Begin
S:=0;
For i:= 1 to n do
    if A[i] > 0 then S:=S+Frac(A[i]);
WriteLn('S = ',S);
End;

Begin
ZAPOLNENIERND();
BbIBOD();
Repeat
WriteLn;
WriteLn('1 - заполнить массив случайными числами');
WriteLn('2 - ввести новое значение заданного элемента');
WriteLn('3 - вычислить сумму дробных частей положительных элементов массива. ');
WriteLn('4 - вывод массива');
WriteLn('9 - выход');
ReadLn(C);
Case C of
1:
  Begin
  ZAPOLNENIERND;
  BbIBOD;
  End;
2:RE;
3:
  Begin
  SF();
  End;
4:BbIBOD;
End
Until C = 9;
End.
0,0(0 оценок)
Ответ:
usachiovavika
usachiovavika
21.04.2020 08:00
@ впервые показали в начале 15 века. Испанские купцы пользовались таким знаком для обмеривания товара. Мера использовалась при покупке скота или вина,это своеобразное сокращение от " arroba",полного названия этой меры. Дальше этот знак использовался в качестве ценника ,а также,пометки для отчётов бухгалтеров. Только после столь длительного пути,этот знак оказался на наших клавиатурах. Рэй Томлинсон стал первым кто сумел отправить настоящее электронное письмо. Электронные коммуникации начали своё развитие именно в тот момент, когда письмо передали между компьютерами-это и было первый e-mail.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота