В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
сабина423
сабина423
28.03.2020 11:52 •  Информатика

с заданиями по информатике 1.Задан двумерный целочисленный массив B из n строк и m столбцов (1 ≤ n, m ≤ 10). На одном из языков программирования (Pascal, C++, Python, алгоритмический язык) cоставить программу, которая которая организует одномерный массив С, элементы которого равны количеству положительных элементов в строке исходного массива В.

2. Задан двумерный целочисленный массив L размера n × n (1 ≤ n ≤ 10). На одном из языков программирования (Pascal, C++, Python, алгоритмический язык) для каждого столбца определить сумму тех двух элементов, которые принадлежат главной и побочной диагоналям.

3. Известный исследователь, устав от долгого путешествия по джунглям, лег спать в 10 часов вечера. Перед этим он завел будильник на 12 часов следующего дня. К сожалению, проспать 14 часов ему не удалось, так как будильник зазвонил уже через 2 часа. Исследователь забыл, что на будильнике, имеющем 12-ти часовой циферблат, можно задать время до звонка только менее 12 часов. Требуется написать программу, которая определяет, сколько часов успеет проспать исследователь, прежде чем будильник его разбудит. Описание входных данных Входные данные вводятся с клавиатуры или из файла input.txt. В единственной строке записаны два целых числа S и T (1 ≤ S, T ≤ 12), разделенные одним пробелом – час, когда исследователь лег спать, и час, на который он установил будильник. Описание выходных данных Выходные данные выводятся на экран или в файл output.txt. В единственной строке необходимо вывести одно целое число – через сколько часов зазвонит будильник.

Показать ответ
Ответ:
леракулдошина
леракулдошина
01.04.2020 10:20
Информация, представленная в компьютере в виде двоичного кода (удобном для компьютерного представления) называется данными.

Алгоритм, записанный на языке программирования и предназначенный для выполнения на компьютере, называется программой. 

Минимальный набор ПК — системный блок, монитор, клавиатура. (иногда ещё зачем-то добавляют мышь)

Центральное устройство компьютера, предназначенное для обработки данных в соответствии с программой, называется процессором. 

Устройства ввода переводят информацию с языка человека на язык компьютера.

Устройства вывода переводят информацию с двоичного языка в привычную для человека форму.

Память компьютера делится на внутреннюю и внешнюю.

Программы и данные в процессе работы хранятся в оперативной памяти компьютера.

После выключения компьютера данные и программы хранятся в энергонезависимой памяти компьютера.

Важнейшая характеристика процессора разрядность. Измеряется она в битах и у современных компьютеров составляет 64 бита.

Вторая важнейшая характеристика процессора тактовая частота, измеряется в МГц, у современных компьютеров может достигать 3.7 ГГц.

К устройствам ввода относятся такие устройства как клавиатура, мышь, сканер, джойстик, микрофон, сенсорный экран, графический планшет.

Важнейшая характеристика графических устройств ввода — разрешающая измеряемая в dpi (точки на дюйм), 1 дюйм = 2,54 см.

К устройствам вывода относятся: монитор, принтер, колонки. 

Расположите устройства внешней памяти в порядке убывания их объёма: CD-ROM, жёсткий диск, дискета, DVD-ROM: Жесткий диск > DVD-ROM > CD-ROM > дискета.
0,0(0 оценок)
Ответ:
asarapik
asarapik
24.03.2023 02:59

ответ:ОБЪЯВЛЕНИЕ МАССИВА

Массивы в Паскале используются двух типов: одномерные и двумерные.

Определение одномерного массива в Паскале звучит так: одномерный массив — это определенное количество элементов, относящихся к одному и тому же типу данных, которые имеют одно имя, и каждый элемент имеет свой индекс — порядковый номер.

Описание массива в Паскале (объявление) и обращение к его элементам происходит следующим образом:

Описание массива в Паскале

Объявление массива

var dlina: array [1..3] of integer;

begin

dlina[1]:=500;  

dlina[2]:=400;  

dlina[3]:=150;

...

dlina — идентификатор (имя) массива;

для объявления используется служебное слово Array (в переводе с англ. «массив» или «набор»);

[1..3] — в квадратных скобках ставится номер (индекс) первого элемента, затем две точки и индекс последнего элемента массива, т.е. по сути, указывается количество элементов; количество элементов массива называется размерностью массива

of integer (с англ. «из целых чисел») — указывает, к какому типу относится массив, of здесь — служебное слово.

 

Объявить размер можно через константу:

размер массива через константу

ИНИЦИАЛИЗАЦИЯ МАССИВА

Кроме того, массив может быть сам константным, т.е. все его элементы в программе заранее определены. Описание такого массива выглядит следующим образом:

const a:array[1..4] of integer = (1, 3, 2, 5);

Заполнение последовательными числами:

заполнение массива

Результат:

A[1] = 8, A[2] = 9, A[3] = 10, ..., A[N] = A[N-1] + 1

Ввод с клавиатуры:

Пример: Рассмотрим, как происходит ввод массива в Паскале:

writeln ('введите кол-во элементов: ');

readln(n); {если кол-во заранее не известно, - запрашиваем его}

for i := 1 to n do begin

  write('a[', i, ']=');

  read(a[i]);

  ...

end;

...

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота