В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Алинур13
Алинур13
20.12.2020 00:29 •  Информатика

С1.написать программу, которая запрашивает число с клавиатуры и сообщает его квадрат, затем спрашивает пользователя «нужно продолжить работу? », и пользователь отвечаетда/нет. программа заканчивает свою работу, если пользователь напечатал слово «нет» на очередной вопрос программы, иначе считает и выдаёт ответ дальше. 2. дан массив из 10-ти чётных натуральных чисел – от 2 до 20. а) найдите сумму элементов массива.б) найдите минимальный элемент массива. 3. дан массив из 15 подряд идущих натуральных чисел, начиная с 50.а) найдите произведение элементов массива.б) найдите максимальный элемент массива.

Показать ответ
Ответ:
marelmrub
marelmrub
02.07.2020 11:21
Второе
var A: array [1..10] of integer;
I,S: integer;
min:=a[1];
beginfor I:=1 to 10 do
begin
a[i]:=random(10);
S:=S+A[I];
write(a[i],' ');
end;
for i:=2 to 10 do 
 begin   
 if min>a[i] then       
min:=a[i]; 
end;
writeln;
writeln ('сумма=',S);
writeln ('минимальное=',min);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота