В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
LizaIvaskevich
LizaIvaskevich
02.01.2023 12:49 •  Информатика

С1. составить алгоритм и написать программу на вычисление скорости или пути , при условии , если t< 3 часов , тогда вычисляем скорость иначе путь . каждую строку программы прокомментировать . входные данные t = 80 мин.

Показать ответ
Ответ:
Gala137
Gala137
01.10.2020 21:59
Алгоритм:
Начало
Ввод t
Если t>1 часа, то 
начать выполнение операторов
ввод S;
V=S/t;
вывод V
закончить выполнение операторов
иначе 
начать выполнение операторов
ввод V;
S=Vt;
вывод S;
закончить выполнение операторов

Var S,V,t:integer;
begin
read(t);
if t>1 then
begin
read(s);
v:=s/t;
writeln('Скорость=',v);
end
else
begin
read(v);
s:=v*t;
writeln('Расстояние=',s);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота