В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kirra00787p07znc
kirra00787p07znc
30.11.2020 04:52 •  Информатика

Самая известная программа, написанная на языке Python, — это популяр- ная социальная сеть Instagram.
Отвечаем на вопросы
1. Что такое алгоритм?
2. Какую команду нужно выполнить, чтобы открыть новое
окно в программе?
3. Для чего нужен язык программирования Python?
4. Каково назначение функции print?
Думаем и обсуждаем
Для чего применяется аргумент с именем sep= пп?​


Самая известная программа, написанная на языке Python, — это популяр- ная социальная сеть Instagram.

Показать ответ
Ответ:
makskolisnik9ouay08
makskolisnik9ouay08
31.07.2021 04:53

Программа:

Python:

Известны координаты вершин A, B, C треугольника. Напишите программу, вычисляющую площадь этого треугольника.

xa = int(input('xa = '))

ya = int(input('ya = '))

xb = int(input('xb = '))

yb = int(input('yb = '))

xc = int(input('xc = '))

yc = int(input('yc = '))

AB = pow((xb - xa)**2 + (yb - ya)**2, 1/2)

BC = pow((xc - xb)**2 + (yc - yb)**2, 1/2)

AC = pow((xc - xa)**2 + (yc - ya)**2, 1/2)

p = (AB + BC + AC) / 2

s = pow(p*(p - AB)*(p - BC)*(p - AC), 1/2)

print('s =', round(s))

Результат:

xa = 2

ya = 1

xb = 6

yb = 5

xc = 10

yc = 1

s = 16

0,0(0 оценок)
Ответ:
Zexory
Zexory
26.08.2022 09:48

import datetime

now = datetime.datetime.now()

now = str(now)

now = now.replace('-', '.')

now = now[:10]

now = now[5:]

a = [['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.18'], ['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12'], ['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12'], ['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12'], ['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12'], ['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12'],['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12'], ['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12'], ['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12'], ['ФАМИЛИЯ', 'ИМЯ', 'ОТЧЕСТВО', '1999.12.12']]

b = []

for i in range(len(a)):

   item = a[i][3][5:]

   if item == now:

       b.append(a[i])

print('СЕГОДНЯ ДЕНЬ РОЖДЕНИЕ У:')

for j in range(len(b)):

   print(b[j][0], b[j][1], b[j][2])


Заданы данные о n=10 учащихся класса: фамилия, имя, отчество, дата рождение (год, номер месяца и чис
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота