Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
DenisKazansev
01.08.2020 12:07 •
Информатика
Сблок схемы или паскаля. составь те алгоритм для решения следуюшей залачи. среди n произвольных вещественных чисел. найдите количество неравных нулю.
Показать ответ
Ответ:
Imfind
01.09.2020 06:57
// PascalABC.NET 3.2, сборка 1467 от 02.06.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrReal('Вводите:',ReadInteger('n='));
Writeln('Количество нулевых равно ',a.Where(x->x=0).Count)
end.
Пример
n= 8
Вводите: 3 1.5 -2.4 0 8 0 0.2 1
Количество нулевых равно 2
0,0
(0 оценок)
Ответ:
cvvb
01.09.2020 06:57
Var n,i,k:integer;
a:array [1..50] of real;
begin
write('Введите целое N = '); readln(n);
for i:=1 to n do
begin
write('a[',i,'] = '); readln(a[i])
end;
k:=0;
for i:=1 to n do
if a[i]<>0 then k:=k+1;
writeln('k = ',k)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
JennieBlackpink1996
19.01.2023 22:52
Напишите программу, которая после ввода двух натуральных чисел возводит первое число в степень второго...
Vikadianalol
02.03.2023 22:37
2.Выполните вычитание двойчных чисел: и третий...
DashaTopjfnfvv
02.03.2023 22:37
Какой из непрерывных сигналов 1-3 может быть представлен приведённой ниже таблицей?...
BackTiger007
25.08.2021 13:02
Дано масив Y(Y1...Y25), знайти максимальний елемент масиву (блок-схема ть......
kaldyn007
25.08.2021 13:02
Какой из непрерывных сигналов 1-3 более всего соответствует данномудискретному сигналу очень контрольная...
шахноза31
26.03.2020 20:30
5 класс ТЖБ СОЧ информатика ребусты шешип бериндерши отиниш...
ZaykaYmnik
19.01.2021 12:38
Диапазон индексов определяет максимально возможное количество элементов в массиве:...
poshel0naher
04.01.2020 15:32
Н Упорядоченная последовательность данных, состоящая из конечного числа элементов, имеющих один и тот же тип, и обозначаемая одним именем: ...
nyushanyusha20owzt36
10.07.2022 10:18
Реализуйте с языка программирования C# вычисления таких значений описательной статистики: - выборочное среднее значение; - выборочная дисперсия; - стандартное отклонение; -...
варя373
22.08.2020 00:29
Какими можно заполнить массив...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrReal('Вводите:',ReadInteger('n='));
Writeln('Количество нулевых равно ',a.Where(x->x=0).Count)
end.
Пример
n= 8
Вводите: 3 1.5 -2.4 0 8 0 0.2 1
Количество нулевых равно 2
a:array [1..50] of real;
begin
write('Введите целое N = '); readln(n);
for i:=1 to n do
begin
write('a[',i,'] = '); readln(a[i])
end;
k:=0;
for i:=1 to n do
if a[i]<>0 then k:=k+1;
writeln('k = ',k)
end.