Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
0Alis11
10.02.2022 00:36 •
Информатика
Сблок схемы или паскаля составьте алгоритм для решения следующей : среди n произвольных вещественных чисел найдите количество не равных нулю.
Показать ответ
Ответ:
san4ez77
09.08.2020 07:54
Var n,i,k:integer;
a:array [1..50] of real;
begin
write('Введите целое N = '); readln(n);
for i:=1 to n do
begin
write('a[',i,'] = '); readln(a[i])
end;
k:=0;
for i:=1 to n do
if a[i]<>0 then k:=k+1;
writeln('k = ',k)
end.
0,0
(0 оценок)
Ответ:
svetlana898
09.08.2020 07:54
Var n,i,k:integer;
a:array[1..1000] of real;
begin
readln(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if a[i]<>0 then inc(k);
write(k);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
lebedevan189
14.08.2020 04:10
решитьB A+1 Λ B 5 V A-B 10при А=10 В=15...
leradorozhnyak
28.07.2020 04:40
Таблица! 1. Для каждого из приведённых имён ЛОЖНО высказывание: НЕ (первая буква гласная) ИЛИ (последняя буква гласная)? 1)Анна 2)Максим 3) Татьяна 4) Егор 2.Для каждого из приведённых...
levgoncharenko
30.06.2021 07:10
Определите результат работы программы. Запишите матема- тическую формулу для вычисления значения from math import a = 12 . b = 5 с = 13 р = (a + b + c) / 2 S = p с *= p - а S =...
dauletkulova
17.06.2021 18:15
, люди! 10 класс, написать программы на Python. задачи на фото !...
violettavladimirovna
13.05.2020 20:58
побудуйте графік функції у =|х2-8|х|-2|.За графіком визначте нулі функ ції, точки мінімуму і максимуму, мінімальні та максимальні значення функції...
qooperty
23.01.2021 09:57
Введите название месяца. если месяц май , то вывести весна пришла! . в любом случае вывести я люблю весну! .паскаль...
Hemmgirl
09.06.2021 15:09
Составить программу нахождения дискриминанта в pascal....
gabjagYT
07.07.2022 15:51
Объясните как это делать? для какого из значений числа х истинно высказывание : не (х 5) и (х 6)?...
JessyMurMur
07.07.2022 15:51
Объясните как это делать? для какого из значений числа х истинно высказывание : (число 75) и не (число чётное)...
кошка452
07.01.2022 22:37
Скажите что такое устройства для ввода звука и что такое устройства для вывода звука...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
a:array [1..50] of real;
begin
write('Введите целое N = '); readln(n);
for i:=1 to n do
begin
write('a[',i,'] = '); readln(a[i])
end;
k:=0;
for i:=1 to n do
if a[i]<>0 then k:=k+1;
writeln('k = ',k)
end.
a:array[1..1000] of real;
begin
readln(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if a[i]<>0 then inc(k);
write(k);
end.