Считать с клавиатуры массив из 10 чисел. Вывести на экран количество пар чисел, сумма которых четная. Под парой чисел подразумевается 2 подряд идущих элемента массива.
2. Заполнить массив из 20 чисел случайными значениями в диапазоне от -40 до 40. Вывести на экран данный массив в строку и количество четных чисел.
3. Написать программу,которая в одномерном массиве из 10 чисел находит максимальны и минимальный элемент.
const
n = 4;
var
a: array[1..n, 1..n] of integer;
i, j, s: integer;
sr: real;
begin
s := 0;
Writeln('Исходная матрица');
for i := 1 to n do
begin
for j := 1 to n do
begin
a[i, j] := Random(256);
Write(a[i, j]:5);
s := s + a[i, j]
end;
Writeln
end;
sr := s / sqr(n);
Writeln('Средняя яркость', sr);
Writeln('Результирующая матрица');
for i := 1 to n do
begin
for j := 1 to n do
begin
if a[i, j] <= sr then a[i, j] := 0 else a[i, j] := 255;
Write(a[i, j]:5)
end;
Writeln
end
end.
Тестовое решение:
Исходная матрица
108 247 9 175
10 80 123 80
75 165 82 128
167 168 6 27
Средняя яркость103.125
Результирующая матрица
255 255 0 255
0 0 255 0
0 255 0 255
255 255 0 0
var a,b,c:integer;
label l1,l2;
begin
l1:
writeln ('Укажите стороны треугольника:'); read (a,b,c);
if (a<=0) or (b<=0) or (c<=0) then begin
writeln ('Проверьте правильность введенных данных'); goto l1;
end;
if (a=b) and (a=c) and (b=c) then begin
writeln ('Треугольник с указанными параметрами - равносторонний'); goto l2; end;
if (a=b) or (a=c) or (b=c) then begin
writeln ('Треугольник с указанными параметрами - равнобедренный'); goto l2;
end;
writeln ('Треугольник с указанными параметрами - разносторонний');
l2:
end.