В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Карик007
Карик007
20.12.2022 07:47 •  Информатика

Сделать на pascalabc, попросили сделать с записей. составить программу, которая вводит данные о студентах: № п/п, фамилию, год рождения, пол, курс, вид спорта и выводит: выводит данные только о спортсменках по курсам и спорта в алфавитном порядке.

Показать ответ
Ответ:
zhan1205
zhan1205
08.07.2020 07:49
const n=3;
type student=record
fam:string[20];
year:integer;
sex:string[1];
kurs:integer;
sport:string[30];
end;
var x:array[1..n] of student; i,j:integer;
p:student;
begin
for i:=1 to n do
with x[i] do begin
writeln('сведенья о ',i,' студенте:');
writeln('фамилия: ');
read(fam);
writeln('год рождения: ');
read(year);
writeln('пол( м или ж ): ');
read(sex);
writeln('курс: ');
read(kurs);
writeln('вид спорта: ');
read(sport);
end;

for i:=1 to n-1 do
for j:=i+1 to n do
if x[i].fam>x[j].fam then begin
p:=x[i];
x[i]:=x[j];
x[j]:=p;
end;
for i:=1 to n do begin
with x[i] do
if (sex='ж') then writeln('Фамилия студентки: ',fam,' Курс: ',kurs,' Вид спорта:  ',sport);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота