В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
главный8
главный8
15.08.2020 16:26 •  Информатика

Сделать на паскале Напишите программу, которая заменяет в символьной строке все буквы «а» на буквы «б» с цикла «пока» (while):
2) 11. Запишите какое значение будет иметь переменная s после вы-полнения фрагмента программы
s:= '123456789'
вставить('ABC', s, 3) s:= '123456789';
Insert('ABC', s, 3);

Показать ответ
Ответ:
karolinaivanova10
karolinaivanova10
06.03.2021 11:28

1)

var

 S : String;

begin

 readln(s);

while (Pos('а', S) > 0) or (Pos('a', S) > 0) do

   begin

     if Pos('а', S) > 0 then

       S[Pos('а',S)] := 'б'

         else

           S[Pos('a', S)]:= 'b';

   end;

writeln(S);

end.

2)

12ABC3456789

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота