В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
sapro95
sapro95
13.11.2021 13:24 •  Информатика

сделать программу на c# кому не сложно! В соответствии с заданным вариантом написать программу, используя
оператор цикла while() или do while()
Задание:
С клавиатуры вводится число N (int). Определить, может ли
оно быть двоичным (т. е. состоять только из 1 и 0) при цикла for.

Показать ответ
Ответ:
милана36
милана36
11.10.2021 09:20

using System;

namespace restless

{

   class Program

   {

       static void Main(string[] args)

       {

           int N;

           bool _isBin = true;

           N = Convert.ToInt32(Console.ReadLine());

           N = Math.Abs(N);

           while (N > 0)

           {

               if (N % 10 != 0 && N % 10 != 1)

               {

                   _isBin = false;

                   break;

               }

               N /= 10;

           }

           Console.WriteLine(_isBin);

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота