В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
mkudryavceva10
mkudryavceva10
03.02.2020 11:32 •  Информатика

сделать в python 1. Имеются три множества символьного типа y1=[‘a,’b’,’d’,’r’,’m’], y2=[‘r’,’a’,’h’,’d’], y3=[‘a’,’r’]. Сформировать множество, полученное в результате X=(y1+y2)*(y1-y2). Вывести на экран элементы всех множеств. Далее проверить, включено ли множество y3 во множество x/
2. Переменной x присвоить множество всех целых чисел от –12 до 12, переменной y – множество всех положительных из этого диапазона, а переменной z – множество всех отрицательных чисел из этого диапазона.

Показать ответ
Ответ:
Сарфароз03
Сарфароз03
23.01.2021 23:23

Так как язык не указан, приведу пример на SWI-Prolog.

Код:

read_int(Int) :- read(Int), integer(Int).split_int_by_numbers(0, []) :- !.split_int_by_numbers(N, [Number|Ints]) :- Number is mod(N, 10), RestN is div(N, 10), split_int_by_numbers(RestN, Ints).test_to_div(_, []).test_to_div(N, [Number|Ints]) :- mod(N, Number) =:= 0, test_to_div(N, Ints). test(Int) :- split_int_by_numbers(Int, Numbers), test_to_div(Int, Numbers), write(Int), write(" - Yes!"), nl.test(Int) :- write(Int), write(" - No!"), nl.?- read_int(Int), test(Int).
Напишите программу: С клавиатуры вводится трёхзначное число (число десятков и число единиц не равна
Напишите программу: С клавиатуры вводится трёхзначное число (число десятков и число единиц не равна
Напишите программу: С клавиатуры вводится трёхзначное число (число десятков и число единиц не равна
0,0(0 оценок)
Ответ:
tigertuborg
tigertuborg
04.05.2022 00:28

uses crt;

const raz=[' ','.',',','?','!'];{/разделители слов, можно добавить}

var s,sl:string;

   i,k:byte;

begin

clrscr;

writeln('Строка:');

readln(s);

writeln('Слово:');

readln(sl);

k:=0;

for i:=1 to length(s) do{идем по строке}

if(s[i]=sl[1])and((s[i-1] in raz)or(i=1)){если символ равен первому символу слова

а перед ним разделитель или начало строки}

and((s[i+length(sl)] in raz)or(i+length(sl)=length(s))){и после слова разделитетль или конец строки}

and(copy(s,i,length(sl))=sl){и все буквы на интервале равны слову}

then k:=k+1;{считаем}

write('Слово ',sl,' встречается ',k,' рз.');

readln

end.

Объяснение:

на каком языке? (В ответе паскаль)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота