В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
fox3221
fox3221
26.06.2022 23:50 •  Информатика

Сэкзаменом pascal: 1 : треугольник задан координатами своих вершин на плоскости. составить программу, которая определит, является ли он равносторонним, равнобедренным или разносторонним 2 : дано целое число n (n > 1). найти наибольшее целое число i, при котором выполняется неравнество 3^i < n

Показать ответ
Ответ:
Соня12131415
Соня12131415
08.10.2020 21:31
PascalABC.NET 3.4

function L(x1,y1,x2,y2:real):=Sqrt(Sqr(x2-x1)+Sqr(y2-y1));

begin
  var (xa,ya):=ReadReal2('Введите координаты точки А(х,у):');
  var (xb,yb):=ReadReal2('Введите координаты точки B(х,у):');
  var (xc,yc):=ReadReal2('Введите координаты точки C(х,у):');
  var a:=L(xb,yb,xc,yc);
  var b:=L(xc,yc,xa,ya);
  var c:=L(xb,yb,xa,ya);
  var k:=a=b?1:0;
  k+=a=c?1:0;
  k+=b=c?1:0;
  case k of
  0:Writeln('разносторонний');
  1:Writeln('равнобедренный');
  else Writeln('равносторонний');
  end
end.



begin
  var n:=ReadInteger('n=');
  var i:=Trunc(Ln(n)/Ln(3));
  if 3**i=n then i-=1;
  Writeln(i)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота