В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
keckush
keckush
04.05.2020 16:53 •  Информатика

Сформировать массив целых чисел [-20...20]. Найти минимальный элемент и его номер. Написать программу в C++

Показать ответ
Ответ:
Викуська2531
Викуська2531
12.11.2021 19:08

Задача 1

var

 x1, y1, x2, y2, l: real;

begin

 Writeln('Введите значения (x1,y1,x2,y2)');

 Read(x1, y1, x2, y2);

 l := Sqrt(Sqr(x1 - x2) + Sqr(y1 - y2));

 Writeln('Расстояние: ', l:3:2);

end.

Тестовое решение:

Введите значения (x1,y1,x2,y2)

2 3 4 5

Расстояние: 2.83

Задача 2

var

 a, b, c, p, s: real;

begin

 Writeln('Введите ABC');

 Read(a, b, c);

 P := (a + b + c)/2;

 S := Sqrt(p * (p - a) * (p - b) * (p - c));

 Writeln('Площадь по Герону: ', S:3:2);

end.

Тестовое решение:

Введите ABC

2 3 4

Площадь по Герону: 2.90

0,0(0 оценок)
Ответ:
3231561
3231561
24.09.2020 07:30
1. Внутреннюю — оперативную и внеш¬нюю — долговременную
2. Управление устройствами и задачами
3. Красный, зеленый, синий
4. Целые числа в памяти компьюте¬ра это:
Дискретное и конечное множество
5. Контроллер
6. Передача данных, передача адресов

7. D

8. Прикладные программы общего назначения и специализированные программы
9. Главная формула информатики?
2i = N
16i = N
2f = Z
2i = M

10. Прикладные программы и системные программы

11. К основным типам устройств оперативной памяти относятся?
Динамическая и статическая память
12. Компьютер
13. Какой универсальный звуко¬вой формат файлов используется для сохранения звука без потерь?
WAV

14. Множество целых чисел в компьютере дискретно, конечно, ограничено

15. В памяти компьютера числа хранятся?
В двоичной сис¬теме счисления

16. Архитектура персонального компьютера это?
Общие принципы построения компьютера

17. Как называется инструмент для работы профессиональных программистов?
Многопользовательские и многозадачные системы программирования

18. Какой термин считается правильным о представлении о множестве целых чисел в математике?
Множество целых чисел дискретно, бесконечно, неограниченно

19. Текстовая информация уже дискретна и состоит из?
Отдельных знаков

20. Какую графику применяют при разработке электронных и полиграфических изданий?
Векторная
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота