Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
postnovat
20.01.2022 10:59 •
Информатика
Сформируйте и выведите целочисленный массив содержащий степени двойки от первой до 16
Показать ответ
Ответ:
lolshowsasdasfd
03.10.2020 06:05
Да если судить по предыдущем решению, "в школу снова не хочу!" )))
// PascalABC.NET 3.0, сборка 1156 от 30.01.2016
begin
Range(1,16).Select(x->Power(2,x)).ToArray.Println
end.
Тестовое решение:
2 4 8 16 32 64 128 256 512 1024 2048 4096 8192 16384 32768 65536
Замечание: ToArray. можно выбросить и написать
Range(1,16).Select(x->Power(2,x)).Println - это была просто дань требованию условия зачем-то создать массив и вывести его значения.
0,0
(0 оценок)
Ответ:
mrrosslanp0aahw
03.10.2020 06:05
Program Project1;
var
a:array[1..16] of integer;
i,p:integer;
begin
p:=1;
for i:=1 to 16 do
begin
p:=p*2;
a[ i ]:=p;
writeln(a[ i ])
end;
readln
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Dasha57891
05.11.2022 07:14
Опишите на паскале целочисленный массив из 25элементов...
asiemghulkarimozb3er
12.06.2021 18:58
Задайте значения элементов массива случайным образом из промежутка (-50; 50)...
DashaWolf11
10.03.2021 20:05
Элементы массива по формуле for k: =1 to 10 do a[k]: =4+k*3; запишите первые 5 элементов массива...
Evgenia601
17.12.2022 08:34
Каков шестнадцатый код символа я ? 1) 2а116 2) df16 3) ef16 4) 18016...
hitechnic669857
18.12.2022 20:12
Var ht: array [2..22] of integer; имя сколько элементов в массиве? тип данных в...
rf2048111111ozt4z7
17.01.2022 17:44
Сор по информатике,8 класс 2 четверть...
Aki0510
17.04.2020 15:33
Надо. лвллжяжалаллыьчьслчллчлч...
nicishcina
01.02.2022 22:26
Сделать 14 вариант по ! (11 класс, язык-паскаль, программа delphi 7)...
Hyina
28.09.2022 10:30
Составить программу на C++ для выполнения действий с массивами. Массив X(20). Условие -1...
Асечка05
22.03.2023 10:32
В информационной системе хранятся изображения размером 1024×768 пикселей. При кодировании используется алгоритм сжатия изображений, позволяющий уменьшить размер памяти для...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// PascalABC.NET 3.0, сборка 1156 от 30.01.2016
begin
Range(1,16).Select(x->Power(2,x)).ToArray.Println
end.
Тестовое решение:
2 4 8 16 32 64 128 256 512 1024 2048 4096 8192 16384 32768 65536
Замечание: ToArray. можно выбросить и написать
Range(1,16).Select(x->Power(2,x)).Println - это была просто дань требованию условия зачем-то создать массив и вывести его значения.
var
a:array[1..16] of integer;
i,p:integer;
begin
p:=1;
for i:=1 to 16 do
begin
p:=p*2;
a[ i ]:=p;
writeln(a[ i ])
end;
readln
end.