Сформируйте массив, содержащий 15 элементов, с датчика случайных чисел. Получите новый массив, каждый
элемент которого равен сумме соответствующего исходного
элемента и его квадрата. В полученном массиве найдите
максимальный элемент и его номер. Выведите на экран
исходные и полученные результаты. Напишите программу подробно.
var
arr : array [1..15] of real;
a, max : real;
i : integer;
begin
read (a);
randomize;
for i := 1 to 15 do
arr[i] := random (20);
for i := 1 to 15 do
write (arr[i], ' ');
writeln; writeln;
for i := 1 to 15 do
write ((arr[i] + a) / 2, ' ');
max := arr[1];
writeln;
for i := 3 to 15 do
if i mod 2 = 1 then
if arr[i] > max then max := arr[i];
writeln ('max =', max);
end.
Объяснение:
вот