Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
lmarki2003
26.11.2022 13:00 •
Информатика
Сгенерировать массив из n=11 случайных чисел {-29; 150}, вывести. найти среднее арифметическое положительных и отрицательных чисел, вывести. поменять местами 2-й и 7-й элементы в массиве, вывести полученный массив
Показать ответ
Ответ:
VikaSh86
16.08.2020 12:52
// PascalABC.NET 3.3, сборка 1570 от 04.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(11,-29,150); a.Println;
Writeln('Ср.арифм. положительных: ',a.Where(x->x>0).Average:0:3);
Writeln('Ср.арифм. отрицательных: ',a.Where(x->x<0).Average:0:3);
Swap(a[1],a[6]);
Writeln('Результирующий массив'); a.Println
end.
Пример
91 109 113 119 17 95 41 131 -15 117 -14
Ср.арифм. положительных: 92.556
Ср.арифм. отрицательных: -14.500
Результирующий массив
91 41 113 119 17 95 109 131 -15 117 -14
0,0
(0 оценок)
Популярные вопросы: Информатика
keewowzor2h
05.11.2021 16:11
Даны две точки в плоской прямоугольной системе координат напишите программу определяющую которая из точек находящиеся ближе к началу координат...
katyusha1514111
05.11.2021 16:11
Объясните, для чего разрабатываются сценарии...
manya48
04.02.2023 21:09
Ввазе 1011 в 2 яблок и 9 в 16 груш. сколько всего фруктов в вазе?...
Nasteckay
21.11.2020 17:11
Используя функцию if(), рассчитайте значения функций. Постройте графики функций. Диапазон и шаг выберите самостоятельно...
катя5091
23.01.2020 02:51
. Только ответы, решение не нужно. 1) Пётр составляет слова длиной 6 букв, которые начинаются с гласной буквы. Всего онсмог составить 486 комбинаций слов. Сколько...
vadim88768
28.10.2022 12:33
Составьте таблицы истинности для следующих логических выражений 1. F=(X & -Y) v Z 2. F=X & v X 3. F= (X v Y)& (Y v X) 4. F= v Y) & (Z v X)) &...
davaispi
29.10.2021 08:54
Какая тема объединяет рассказы Ф.А. Абрамова О чем плачут лошади , Е.И. Носова Кукла , Живое пламя , Ю.П. Казакова Тихое утро ?...
SchillerAlice
02.06.2020 03:02
Найдите корни уравнения 3x^2+12x=0 Если корней несколько, запишите их в ответ без пробелов в порядке возрастания....
irakeksik
02.06.2020 03:02
Маленький шарик на нити длиной 1,5 м сместили из положения равновесия на расстояние a = 1 см и предоставили самому себе. За какое время амплитуда колебаний уменьшится...
afdsfdsafdsfdsf
02.06.2020 03:02
Я знаю что во не сложные Что такое медленный бег используемый в разминки .2 В какой африканской стране наиболее развита лёг Атлетико 3 Совокупности легкоатлетических...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(11,-29,150); a.Println;
Writeln('Ср.арифм. положительных: ',a.Where(x->x>0).Average:0:3);
Writeln('Ср.арифм. отрицательных: ',a.Where(x->x<0).Average:0:3);
Swap(a[1],a[6]);
Writeln('Результирующий массив'); a.Println
end.
Пример
91 109 113 119 17 95 41 131 -15 117 -14
Ср.арифм. положительных: 92.556
Ср.арифм. отрицательных: -14.500
Результирующий массив
91 41 113 119 17 95 109 131 -15 117 -14