В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Coul2000nator
Coul2000nator
27.07.2020 21:49 •  Информатика

Си ++, , , нужно написать программу с оператором while, которая будет включать пользовательскую функцию для вычисления значения z

Показать ответ
Ответ:
ВладАхтубинск
ВладАхтубинск
10.10.2020 11:28

Исходник ниже.

Объяснение:

#include <iostream>

#include <cmath>

using namespace std;

int main(){

   //"\t" - табуляция

   //fixed - для вывода фиксированного количества знаков после запятой у вещественного числа

   cout << "x\t\ty\t\ta\t\tb\t\tz" << endl;

   double x = 0.5;

   while(x <= 1.9){

       double y = 0.1;

       while(y <= 0.2){

           double a = cos(x*x*x - sqrt(y));

           double b = pow(x * y * y, 1.0 / 3);

           double z;

           if (a > b){

               z = a;

           }

           else{

               z = b;

           }

           cout << fixed << x << "\t" << y << "\t" << a << "\t" << b << "\t" << z << endl;

           y += 0.05;

       }

       x += 1.1;

   }

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота