В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
даша2149
даша2149
01.04.2022 18:47 •  Информатика

Си++ составить программу, печатающую все простые числа из диапазона [2, n] при целом n > 2.

Показать ответ
Ответ:
gashuna
gashuna
01.10.2020 04:35


#include <iostream>
using namespace std;
int isSimple (int x)
{
int retVal = 1;
int i = 2;
while (i<=sqrt((double)x) && retVal==1)
{
if (x%i==0) retVal=0;
i++;

}
return retVal;
}

void main(){
int n(0);
cout<<"write n "; cin>>n;
if (n < 3)
cout<<"error";
else {
for (int i=2;i<=n;i++)
if (isSimple(i)) cout<<i<<" ";
}
cout<<endl;
system("pause");
}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота