В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Lol2288502
Lol2288502
09.03.2022 20:32 •  Информатика

Скласти блок-схему, та написати програму на мові Паскаль задачі

Знайти суму чисел кратних 7 (тобто діляться на 7) з діапазону від 50 до 300.

Знайти кількість парних чисел з діапазону від 53 до 200.

Составить блок-схему, и написать программу на языке Паскаль задачи

Найти сумму чисел кратных 7 (то есть делятся на 7) в пределах от 50 до 300.

Найти количество четных чисел из диапазона от 53 до 200.

Показать ответ
Ответ:
Vetaliks
Vetaliks
14.06.2020 05:18
// PascalABC.NET 3.2, сборка 1346 от 25.11.2016
// Внимание! Если программа не работает, обновите её версию!

begin
  var n:=30;
  var a:=ArrRandom(n,-15,15); a.Println;
  var mx:=a[0]+a[n-1];
  for var i:=2 to (n-1) div 2 do begin
    var s:=a[i]+a[n-i-1];
    if s>mx then mx:=s
    end;
  Writeln('Максимальная из сумм сходящихся пар: ',mx);
  // сортировка выбором
  var j:=n-1;
  while j>0 do begin
    mx:=a[0];
    var imx:=0;
    for var i:=1 to j do
      if a[i]>mx then begin mx:=a[i]; imx:=i end;
      a[imx]:=a[j];
      a[j]:=mx;
      j-=1
    end;
  a.Println
end.

Пример
-14 9 1 -14 -5 14 -15 -15 -1 -4 -8 -9 1 -12 -11 -3 9 -1 -9 -9 -1 -8 15 -8 5 -13 15 6 9 11
Максимальная из сумм сходящихся пар: 19
-15 -15 -14 -14 -13 -12 -11 -9 -9 -9 -8 -8 -8 -5 -4 -3 -1 -1 -1 1 1 5 6 9 9 9 11 14 15 15
0,0(0 оценок)
Ответ:
inybax
inybax
12.11.2022 17:15
Крч вот на паскале, на Си не могу, сорь

program ;
var
A: array [-1000..1000] of integer;
n, i, b : integer;
begin
    writeln('Введите количество чисел');
    readln(n);
    b:=0;
    for i := 1 to n do
        readln(A[i]);
    for i := 0 to (n) do
        b := b+ A[i];
    write('Это сумма ');
    writeln(b); // Это сумма.
    b:=0;
    for i := 1 to (n) do
    begin
        if A[i] = 0 then
            b := b+1
    end;
    write('Это количество нулей ');
    writeln(b) ;// это количество нулей
    b:= -1001;
    for i := 1 to (n) do
    begin
        if A[i] > b then
            b := A[i]
    end;
    write('Это максимальное число ');
    writeln(b); // Это максимальное число
        b:= 1001;
    for i := 1 to (n) do
    begin
        if A[i] < b then
            b := A[i]
    end;
    write('Это минимальное число ');
    writeln(b) // Это минимальное число
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота