В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Lena89269295717
Lena89269295717
27.04.2023 06:54 •  Информатика

Скласти програму знаходження добутку елементів одновимірного масиву
(Составить программу нахождения произведения элементов одномерного массива

Показать ответ
Ответ:
Максуд22861827
Максуд22861827
11.03.2021 00:23
While (tnum != 0)  //tnum, tden - числитель и знаменатель искомой                                    дроби
    {
        if (tnum < tden)
        {
            temp = tnum;
            tnum = tden;
            tden = temp;
        }
        tnum = tnum - tden;
    }
    gcd = tden;  //вычисляем наибольший общий делитель
    numerator = numerator / gcd;  //делим числитель и знаменатель на
                                                      НОД, получаем сокращенную дробь
    denominator = denominator / gcd;
0,0(0 оценок)
Ответ:
lisi4ka228666
lisi4ka228666
13.04.2020 00:12
// PascalABC.NET 3.1, сборка 1198 от 11.03.2016
begin
  var k:=0;
  var Terminate:boolean;
  repeat
    Terminate:=True;
    var n:=ReadInteger('Введите номер месяца:');
    case n of
    1,3,5,7,8,10,12:Writeln('31 день');
    4,6,9,11:Writeln('30 дней');
    2:Writeln('28 дней в обычном году и 29- в високосном')
    else begin
      Writeln('Вы ошиблись, номер должен быть от 1 до 12');
      Inc(k);
      Terminate:=False
      end
    end
  until Terminate;
  if k>0 then Writeln('Вы ошиблись ',k,' раз(а).')
end.

Тестовое решение:
Введите номер месяца: 18
Вы ошиблись, номер должен быть от 1 до 12
Введите номер месяца: 0
Вы ошиблись, номер должен быть от 1 до 12
Введите номер месяца: 5
31 день
Вы ошиблись 2 раз(а).
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота