Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Клеоок
24.05.2021 20:07 •
Информатика
Склавиатуры вводится число n, а за ним - массив из n целых чисел. найдите номер первого по счёту элемента массива с нечётным значением.
Показать ответ
Ответ:
Заразный1
27.07.2020 17:47
#include <stdio.h>
#include <stdlib.h>
#include <locale.h>
int main(void)
{
setlocale(LC_ALL, "Russian");
int n, iuneven = -1;
scanf("%d", &n);
int *a = (int*)malloc(n * sizeof(int));
for (int i = 0; i < n; i++)
scanf("%d", &a[i]);
for (int i = 0; i < n; i++)
if (a[i] % 2 == 1)
{
iuneven = i;
break;
}
free(a);
iuneven == -1 ? printf("Нечетное число не найдено\n") : printf("%d\n", iuneven);
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
123polinapolina
02.11.2020 08:35
Исполнитель «Сумматор» умеет выполнять две команды: 1. Прибавить 8 2. Умножить на k k – это неизвестное натуральное число, k 1. Выполняя первую команду, исполнитель увеличивает...
Бесконечноенебо
12.09.2022 14:04
РЕШИТЕ В ПИТОН ЧЕРЕЗ WHILE...
ivanignatov201
23.01.2020 16:59
Кодирование информации. Системы счисления: Три степени...
sladenykaya136
02.02.2021 23:37
Сколько файлов с расширением rtf объёмом менее 1000 Кб каждый содержится в подкаталогах каталога DEMO-12? В ответ укажите только число....
kefir9
18.09.2022 09:27
В банкомате имеются в достаточном количестве купюры номиналом 50, 100, 200, 500 и 1000 рублей. Найти минимальное количество купюр, которое необходимо использовать, чтобы...
layonel911
25.01.2020 15:33
Задано целое положительное число. найдите произведение нечетных цифр числа. если таких цифр нет, то вывести об этом сообщение...
WannerBee
15.09.2021 09:17
Выберите графический формат, в котором могут хранится анимированные изображения?...
dashasamoylova2
15.09.2021 09:17
Величина-вес,значение ,единица измерения-кг...
Лисанна2019
19.05.2023 19:57
ответ: 4181. Выберите (отметьте галочкой) действия, которые ибыть выполнены в текстовом процессоре в режимеботы с файлами.которые могутрежиме ра-Открытие файлаРедактирование...
dbb26444
25.12.2020 19:11
Дописать программу квадратные уравнения на языке Паскаля...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <stdlib.h>
#include <locale.h>
int main(void)
{
setlocale(LC_ALL, "Russian");
int n, iuneven = -1;
scanf("%d", &n);
int *a = (int*)malloc(n * sizeof(int));
for (int i = 0; i < n; i++)
scanf("%d", &a[i]);
for (int i = 0; i < n; i++)
if (a[i] % 2 == 1)
{
iuneven = i;
break;
}
free(a);
iuneven == -1 ? printf("Нечетное число не найдено\n") : printf("%d\n", iuneven);
return 0;
}