В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
20Iulia
20Iulia
04.08.2022 05:50 •  Информатика

Склавиатуры вводится слово. составить программу, которая: а) определяет количество символов в нем; б) определяет, ли первая и последняя буквы слова; в) выводит на экран его первый, третий и последний символ; г) определяет, четно или нечетно количество символов в нем.
pascal abc

Показать ответ
Ответ:
sofia060506
sofia060506
10.10.2020 08:17

var s: string;

begin

readln(s);

writeln('кол-во символов: ',length(s));

if s[1]=s[length(s)] then

writeln('первая и последняя буквы слова совпадают')

else writeln('первая и последняя буквы слова не совпадают');

writeln('первый, третий и последний символы: ',s[1],' ',s[3],' ',s[length(s)]);

if length(s) mod 2=0 then write('кол-во символов четное')

else write('кол-во символов нечетное');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота