В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
sernikovs
sernikovs
13.12.2021 22:08 •  Информатика

Склавиатуры вводится строка. с новой строки вводится буква. составьте программу подсчета количества заданных букв в заданной строке. определить, является ли длина введенного слова числом, кратным трем. определить, заканчивается ли введенное слово гласной буквой.

Показать ответ
Ответ:
Mashavicks
Mashavicks
23.06.2020 15:42
Var
  s : string;
  c : char;
  i, a : integer;
begin
  readln (s);
  read (c);  
a := 0;
  for i := 1 to length(s) do if s[i] = c then a := a + 1;
  write (a);
end.

var
  s : string;
begin
  readln (s);
    if length (s) mod 3 = 0  then write ('YES') else write ('NO');
end.

var
  s : string;
begin
  readln (s);
    if s[length (s)] in ['а', 'о',тут через запятую гласные]  then write ('YES') else write ('NO');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота