Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Sonya2308
22.05.2023 11:20 •
Информатика
Склавиатуры вводится строка. заменить в ней слово dog на слово cat. pascal abc
Показать ответ
Ответ:
NeMaximilan
06.10.2020 02:40
Var
S:string;
i,k:integer;
Begin
k:=0;
Write('Введите строку: ');ReadLn(S);
For i:= 1 to Length(S)-2 do
if S[i]='d' then
if S[i+1]='o' then
if S[i+2]='g' then
Begin
S[i]:='c';
S[i+1]:='a';
S[i+2]:='t';
End;
WriteLn('Новая строка: ',S);
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
Varya1111111111113
26.01.2020 03:07
Алгоритм добавление сноски к документу:1.установите курсор в том месте текста, где будет сноска – ссылка на поясняющий текст.2.3.блоке инструментов «Сноски» нажмите кнопку «Вставить...
Nastyaaaaaa34
12.05.2020 17:16
Примеры действий которые можно и нельзя совершать, работая за компьютером? ...
алиса769
28.05.2023 16:30
Прочитай придложэние что их обединяет в первой грппе? а во второй...
Polina68911
28.05.2023 16:30
Циклические алгоритмы 1.найти произведение семи целых чисел, вводимых с клавиатуры. 2. найти сумму чисел от 30 до 20....
sanjar860s
28.05.2023 16:30
1/(1*3)+1/(2*5)+1/(3*5)+1n(n+2) составьте программу вычисления значения выражения...
10154
28.05.2023 16:30
Некоторый алгоритм из одной цепочки символов получает новую цепочку следующим образом. сначала вычисляется длина исходной цепочки символов; если она чётна, то удаляется правый...
Кекушка36
28.05.2021 09:47
Что называют постоянной в программе? а) величину, значение которой может меняться в ходе выполнения программы в) любую величину с) величину, значение которой неизменно в ходе...
Асуна225
28.05.2023 20:10
10 лет- свойства с именем возраст, что это?...
rusakova09
12.02.2020 08:39
Какой вид транспорта по грузообороту занимает первое место (в мо)? ...
Katia15225
27.09.2021 10:03
54. одним из следствий «великих реформ» александра ii является 1) разрушение крестьянской общины; 2) начало промышленного переворота; 3) изменение социальной структуры российского...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
S:string;
i,k:integer;
Begin
k:=0;
Write('Введите строку: ');ReadLn(S);
For i:= 1 to Length(S)-2 do
if S[i]='d' then
if S[i+1]='o' then
if S[i+2]='g' then
Begin
S[i]:='c';
S[i+1]:='a';
S[i+2]:='t';
End;
WriteLn('Новая строка: ',S);
End.