В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
макар95
макар95
26.08.2022 16:39 •  Информатика

Склавиатуры вводиться трёхзначное число ,составить программу которая проверит делиться ли она на сумму своих чисел

Показать ответ
Ответ:
sedoidenis2000
sedoidenis2000
05.10.2020 18:09
Var
A,B:integer;
Begin
WriteLn('Введите целое трёхзначное число');
ReadLn(A);
B:=(A div 100)+((A div 10) mod 10) + (A mod 10);
if (A mod B = 0) then Write(A,' делится на ',B)
else Write(A,' не делится на ',B);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота