В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
kochergina707
kochergina707
27.06.2020 21:22 •  Информатика

Склавиатуры вводят слова.составьте программу,которая выводит цифры этого числа .например: семь нуль три один шесть четыре ,должно вывести 7 0 3 1 6 4

Показать ответ
Ответ:
natik045
natik045
08.09.2020 13:53
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var w1:=Arr('ноль','один','два','три','четыре','пять','шесть',
    'семь','восемь','девять');
  var w2:=Arr('0','1','2','3','4','5','6','7','8','9');
  var a:=ReadlnString('->').ToWords;
  foreach var w in a do begin
    var i:=w1.FindIndex(p->p=w);
    if i>=0 then Write(w2[i],' ')
    end;
end.

Пример
-> семь ноль три один шесть четыре
7 0 3 1 6 4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота