В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Nezlo8
Nezlo8
01.02.2022 03:33 •  Информатика

Склавиатуры вводят строку. составить программу, которая удаляет из строки последнее слово

Показать ответ
Ответ:
Irishka091
Irishka091
13.07.2020 15:27
Program aaa;
var
a,i:longint;
s:string;
begin
read(s);
a:=0;
for i:=1 to length(s) do 
if s[i]=' ' then a:=i; //находим последний пробел
delete(s,a,length(s)-a+1); //удаляем из строки последнее слово
writeln(s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота