Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Russia569
22.06.2021 10:28 •
Информатика
Склавиатуры вводятся координаты вершин треугольника. найти его площадь. программа с++
Показать ответ
Ответ:
Niiiiklou
30.04.2020 19:58
//Microsoft VS 2017 (C++)
//Console application
#include<iostream>
using namespace std;
struct coords {
double x;
double y;
};
double findLen ( double x, double y, double x1, double y1) {
return sqrt(pow(x1 - x, 2) + pow(y1 - y, 2)); //теорема пифагора ( расстояние между двумя точками )
}
double findS( double firstLen, double secLen, double thirdLen) {
double p = (firstLen + secLen + thirdLen) / 2;
return sqrt(p * (p - firstLen) * (p - secLen) * (p - thirdLen)); //формула Герона
}
int main() {
coords A, B, C;
cout << "Input coords for point A : x = "; cin >> A.x;
cout << "\t\t\t y = "; cin >> A.y;
cout << "Input coords for point B : x = "; cin >> B.x;
cout << "\t\t\t y = "; cin >> B.y;
cout << "Input coords for point C : x = "; cin >> C.x;
cout << "\t\t\t y = "; cin >> C.y;
cout << endl << endl; cout << "S for ABC : "<<findS(findLen(A.x,A.y,B.x,B.y), findLen(B.x, B.y, C.x, C.y), findLen(A.x, A.y, C.x, C.y))<<endl;
system("pause"); //если не компилируется, убери эту строку
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
KarinochkaShiну
24.05.2023 03:41
:((совсем не понимаю : ( заполнить случайными целыми числами диапазона от 10 до 25,массив из 10 элементов.вывести его на экран в столбец....
Nawrik34digma
23.06.2022 22:06
Тест. 1)какое из устройств компьютера не входит в состав системного блока? a.процессор b.принтер c.дисковод d.оперативная память 2)для хранения данных в компьютере служит:...
linnik4Platon
18.04.2020 00:55
Какую команду необходимо выбрать для использования готовогошаблона в презентации? a) from templates b) empty presentation c) hide slide d) custom animation ...
Kamilla0707
05.12.2022 18:36
Склавиатуры вводится строка из двух слов, разделённых пробелом. составьте программу, которая определяет : а) начинается ли оба слова с одной и той же буквы; б) начинается...
dfjjrrjsoodkljv
12.01.2021 17:07
Перевод из pascal в c++ var a: array[1..10] of integer; i: integer; begin for i: =1 to 10 do read(a[i)); end....
Nazym99
06.01.2022 00:41
Написати програму, що утворює із цифр тризначного числа найбільше тризначне число/написать программу, образует с цифр трехзначного числа больше трехзначное число...
sebasogo
06.01.2022 00:41
Отметьте объекты операционной системы: рабочий стол окно папка файл компьютер...
DeRellik
19.02.2022 04:53
Какая из перечисленных кодировок включает наибольшее число символов? а)utf-8 б)koi8-r в)windous-1251 г)cp866...
Valeria5780
26.03.2023 09:17
Назови имя объекта,изображённого на рисунке, и напиши это слово: можно ли слово,которым обозначено имя этого объекта, назвать термином информатики? объясни почему....
Princess05082006
26.03.2023 09:17
Ганууся зробила 2 букети зволошок в одному букеті було в 3 рази більше...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
//Console application
#include<iostream>
using namespace std;
struct coords {
double x;
double y;
};
double findLen ( double x, double y, double x1, double y1) {
return sqrt(pow(x1 - x, 2) + pow(y1 - y, 2)); //теорема пифагора ( расстояние между двумя точками )
}
double findS( double firstLen, double secLen, double thirdLen) {
double p = (firstLen + secLen + thirdLen) / 2;
return sqrt(p * (p - firstLen) * (p - secLen) * (p - thirdLen)); //формула Герона
}
int main() {
coords A, B, C;
cout << "Input coords for point A : x = "; cin >> A.x;
cout << "\t\t\t y = "; cin >> A.y;
cout << "Input coords for point B : x = "; cin >> B.x;
cout << "\t\t\t y = "; cin >> B.y;
cout << "Input coords for point C : x = "; cin >> C.x;
cout << "\t\t\t y = "; cin >> C.y;
cout << endl << endl; cout << "S for ABC : "<<findS(findLen(A.x,A.y,B.x,B.y), findLen(B.x, B.y, C.x, C.y), findLen(A.x, A.y, C.x, C.y))<<endl;
system("pause"); //если не компилируется, убери эту строку
return 0;
}