Сколько различных значений числа d можно ввести, чтобы после выполнения программы было напечатано 196? var n, s, d: integer; begin readln(d); n : = 7; s : = 35; while s < = 2570 do begin s : = s + d; n : = n + 9 end; write(n) end.
Функция считает, если коротко n := 7+9*((2570-35) div d + 1) 196 = 7+9*((2570-35) div d + 1) (196-7)/9-1 = (2570-35) div d 20 = 2535 div d 4 = 507 div d 507/4 =126.75, значит можно взять меньше подбором 126 125 124 123 122 121 => 6 чисел
или программой //PascalABC.NET версия 3.2, сборка 1389 //Если программа не запускается, то обновите версию function f(d: integer): integer; var n, s: integer;
begin n := 7; s := 35; while s <= 2570 do begin s := s + d; n := n + 9 end; f := n; end;
begin for var i := 1 to 100000000 do begin if f(i) = 196 then writeln(i); if f(i) <> 7 + 9 * ((2570 - 35) div i + 1) then writeln('not ', i); end; end.
n := 7+9*((2570-35) div d + 1)
196 = 7+9*((2570-35) div d + 1)
(196-7)/9-1 = (2570-35) div d
20 = 2535 div d
4 = 507 div d
507/4 =126.75, значит можно взять меньше
подбором 126 125 124 123 122 121 => 6 чисел
или программой
//PascalABC.NET версия 3.2, сборка 1389
//Если программа не запускается, то обновите версию
function f(d: integer): integer;
var
n, s: integer;
begin
n := 7;
s := 35;
while s <= 2570 do
begin
s := s + d;
n := n + 9
end;
f := n;
end;
begin
for var i := 1 to 100000000 do
begin
if f(i) = 196 then writeln(i);
if f(i) <> 7 + 9 * ((2570 - 35) div i + 1) then writeln('not ', i);
end;
end.