В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
cnastya970
cnastya970
26.03.2023 18:40 •  Информатика

Сложное по информатике: нужно написать программу на паскале, не используя if, then, else, с таким результатом: введите число если число четное, то вывести 10; если нечетное, то вывести -10

Показать ответ
Ответ:
Edinorog1Panda
Edinorog1Panda
03.10.2020 20:44
Var a:integer;
begin
write('a = ');
readln(a);
writeln(-20*(abs(a) mod 2)+10);
end.

Пример:
a = 28
10
0,0(0 оценок)
Ответ:
Lidya777
Lidya777
03.10.2020 20:44
Var
n: integer;
res: boolean;
begin
readln(n);
res:=odd(n);
case res of
true: writeln('-10');
false: writeln('10');
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота