В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
суады
суады
29.07.2022 08:49 •  Информатика

Сложные условия ветвления ! напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке. пример: введите три числа: 5 5 5 все числа одинаковые. пример: введите три числа: 5 7 5 два числа одинаковые. пример: введите три числа: 5 7 8 нет одинаковых чисел.

Показать ответ
Ответ:
ilay23143p0bp8a
ilay23143p0bp8a
06.10.2020 23:14
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  case ReadSeqInteger('Введите три целых числа:',3).Distinct.Count of
  3:Writeln('Нет одинаковых чисел');
  2:Writeln('Два числа одинаковые');
  else Writeln('Все числа одинаковые')
  end
end.

Примеры
Введите три целых числа: 5 5 5
Все числа одинаковые

Введите три целых числа: 5 7 5
Два числа одинаковые

Введите три целых числа: 5 7 8
Нет одинаковых чисел
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота