В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Shaxrior
Shaxrior
26.11.2020 00:55 •  Информатика

Сна паскаль!
составить программу для решения : дано натуральное число n. вычислить , определяемое как произведение честных чисел от 2 до n, если n честно, либо как произведение нечетных чисел от 1 до n, если n нечетно.

Показать ответ
Ответ:
Акося3557
Акося3557
07.10.2020 20:02

program raf105;

var

 n,pro: integer;

begin

 write('n = ');

 readln(n);

 pro:= n;

 while n-2 > 0 do

 begin

   pro:= pro * (n-2);

   n:= n - 2;

 end;

 writeln('Вывод: ',pro);

end.

PascalABC
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота