В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
nyto4ek
nyto4ek
23.01.2023 12:47 •  Информатика

Сортировка выбором. Дан массив A[N]. Требуется переставить элементы так, чтобы они были расположены по убыванию. Для этого в массиве, начиная с первого, выбирается наибольший элемент и ставится на первое место, а первый – на место наибольшего. Затем, начиная со второго, эта процедура повторяется. Написать программу сортировки выбором и протестировать её на трёх различных тестах. Язык программирования - Pascal ABC.

Показать ответ
Ответ:
trubadurov01
trubadurov01
15.01.2023 23:11

2³ = 3 + 5

3³ = 7 + 9 + 11

4³ = 13 + 15 + 17 + 19

Заметим что во втором выражении первое число(7) получается как 3*(3-2)+1

В третьем аналогично: 13 получается как 4*(4-1)+1

Получаем формулу для первого значения: x1 = n*(n-1)+1

Остальные числа получаются путём прибавления 2 к предыдущему слагаемому. Так же заметим что число слагаемых равно числу которое мы возводим в степень.

x = int(input("Введите число: "))

xn = x * (x - 1) + 1  

rezultat = xn  

while (x != 1):

   xn += 2

   rezultat += xn

   x -= 1

 

print("Результат возведения в 3 степень:", rezultat)

0,0(0 оценок)
Ответ:
Tamik7895
Tamik7895
06.02.2022 16:25

Как заполнить массив случайными числами в диапазоне от 100 до 200?

С каких функций можно найти сумму и количество элементов массива?

Как заполнить массив случайными числами в диапазоне от 100 до 200?

С каких функций можно найти сумму и количество элементов массива?

Объяснение:

Как заполнить массив случайными числами в диапазоне от 100 до 200?

С каких функций можно найти сумму и количество элементов массива?

Хахахахазаахахаха какой привет такой ответ гони 5 Как заполнить массив случайными числами в диапазоне от 100 до 200?

С каких функций можно найти сумму и количество элементов массива?

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота