Sos! 2 день уже мучаюсь не могу составить программу, что бы я не делала она не работает. составить программу для подсчета количество глухих согласных в тексте, чтоб было много copy
Это, конечно, ужасный вариант с "много Copy", но если надо ... Program primer4; var s:string; i,k:integer; begin writeln('подсчет количества глухих согласных в тексте'); writeln('введите текст'); readln(s); k:=0; for i:=1 to length(s) do if (copy(s,i,1)='к')or(copy(s,i,1)='п')or(copy(s,i,1)='с')or (copy(s,i,1)='т')or(copy(s,i,1)='ф')or(copy(s,i,1)='х')or (copy(s,i,1)='ц')or(copy(s,i,1)='ч')or(copy(s,i,1)='ш')or(copy(s,i,1)='щ') then k:=k+1; writeln(k); end.
Пример: подсчет количества глухих согласных в тексте введите текст подсчет количества глухих согласных в тексте 17
Program primer4;
var s:string; i,k:integer;
begin
writeln('подсчет количества глухих согласных в тексте');
writeln('введите текст');
readln(s);
k:=0;
for i:=1 to length(s) do
if (copy(s,i,1)='к')or(copy(s,i,1)='п')or(copy(s,i,1)='с')or
(copy(s,i,1)='т')or(copy(s,i,1)='ф')or(copy(s,i,1)='х')or
(copy(s,i,1)='ц')or(copy(s,i,1)='ч')or(copy(s,i,1)='ш')or(copy(s,i,1)='щ')
then k:=k+1;
writeln(k);
end.
Пример:
подсчет количества глухих согласных в тексте
введите текст
подсчет количества глухих согласных в тексте
17