В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
julia071201
julia071201
03.11.2021 01:00 •  Информатика

Составить алгоритм и написать программу, позволяющую найти среднее арифметическое элементов массива, превосходящих некоторое число с. массив задан датчиком случайных чисел на интервале [-44, 35]. размер произвольный. значение с вводится с клавиатуры.

Показать ответ
Ответ:
ilovemath777
ilovemath777
07.10.2020 17:29
//PascalABC.NET 3.3,сборка 1611 от 06.01.2018

//Внимание! Если программа не работает, обновите версию!

begin

  var mas:=ArrRandom(10,-44,35); var c:=readinteger('C=');

  Writeln('среднее арифметическое =',mas.Where(t->t>c).Average);

end.

Как учат в школе ->

var mas:Array [1..20] of integer;

i,k,c:integer; l:real;

begin

randomize;

for i:=1 to 20 do

mas[i]:=Random(-44,35);

Write('C='); readln(c);

for i:=1 to 20 do

if mas[i]>c then

k:=k+mas[i];

l:=k/20;

Writeln('среднее арифметическое =',l);

end.
Составить алгоритм и написать программу, позволяющую найти среднее арифметическое элементов массива,
Составить алгоритм и написать программу, позволяющую найти среднее арифметическое элементов массива,
Составить алгоритм и написать программу, позволяющую найти среднее арифметическое элементов массива,
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота