Составить алгоритм и написать программу позволяющую найти сумму элементов массива с четными номерами содержащего n элементов заполнение массива организовать натуральными числами в порядке убывания надо
Блок-схема - в прилагаемом файле. Программа: const n=10; var a:array[1..n] of integer; s,i:integer; begin for i:=1 to n do begin a[i]:=n-i+1; write(a[i],' '); end; writeln; s:=0; for i:=1 to n div 2 do s:=s+a[2*i]; writeln('s = ',s); end.
Программа:
const n=10;
var a:array[1..n] of integer;
s,i:integer;
begin
for i:=1 to n do begin
a[i]:=n-i+1;
write(a[i],' ');
end;
writeln;
s:=0;
for i:=1 to n div 2 do s:=s+a[2*i];
writeln('s = ',s);
end.
Результат:
10 9 8 7 6 5 4 3 2 1
s = 25