В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
55vitalik
55vitalik
10.09.2020 22:47 •  Информатика

Составить алгоритм, написать программу, которая заполняет массив из 20 данных случайными числами и делят его на два массива, в один помещает четные числа в другой нечетные. вывести исходный массив, массив четных чисел и нечетных чисел.

Показать ответ
Ответ:
Groyve1
Groyve1
01.10.2020 07:21

var

  a,b,c:array [1..20] of integer;

  i,k,l:integer;

begin

  randomize;

  k:=1;

  l:=1; 

  writeln ('Исходный массив: '); 

  for i:=1 to 20 do

   begin

    a[i]:=random(9)+1;

    if a[i] mod 2 = 0 then

     begin

      b[k]:=a[i];

      inc(k);

     end else

      begin

       c[l]:=a[i];

       inc(l);

      end; 

    write (a[i],' ');

  end;

  k:=k-1;

  l:=l-1; 

  writeln;

  writeln ('Массив четных чисел');

  for i:=1 to k do write (b[i],' ');

  writeln;

  writeln ('Массив нечетных чисел');

  for i:=1 to l do write (c[i],' ');

  writeln;

  readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота