В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ИзмМалика
ИзмМалика
08.08.2020 08:15 •  Информатика

Составить алгоритм решения согласно своему варианту и написать программу на языке с++. в отчете предоставить блок-схемы функции : вводится последовательность целых чисел, 0 – конец последовательности.для каждого числа последовательности проверить, представляют ли его цифры строго возрастающую последовательность, например, 1234(результатом функции будет 1 – да, 0 - нет).

Показать ответ
Ответ:
nataotkidach
nataotkidach
12.07.2020 01:48
#include <iostream>
int main()
{
    int n;
    bool flag = true;
    std::cin >> n;
    while(n != 0) \\!Ожидаем появления на входе нуля
    {
        while (n >= 10) 
        {
            if(n / 10 % 10 >= n % 10) \\!Сравниваем две последние цифры в числе
                flag = false; \\!Если не совпадает с условием, flag = false, т.е. выведется 0
            n = n / 10;
        }
        std::cout << flag << std::endl;
        flag = true;
        std::cin >> n;
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота