В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
kabilet777
kabilet777
14.01.2023 19:02 •  Информатика

Составить блок-схему и написать программу для определения суммы нечетных цифр некоторого числа n. указание: для того, чтобы взять одну цифру из заданного числа n необходимо использовать операцию n mod 10.

Показать ответ
Ответ:
И1111111111111111
И1111111111111111
08.10.2020 05:41
Замечание: считается, что число N - натуральное.
Блок-схема - в прилагаемом файле.
var a,s:integer;
begin
readln(a);
s:=0;
while a>0 do
 begin
 if a mod 2=1 then s:=s+a mod 10;
 a:=a div 10;
 end;
writeln('s = ',s);
end.

Пример:
1234567
s = 16
Составить блок-схему и написать программу для определения суммы нечетных цифр некоторого числа n. ук
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота