В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
spl228
spl228
17.04.2020 03:30 •  Информатика

Составить блок-схему и написать программу на языке pascalabc.net. 1. три сопротивления r1, r2, r3 соединены параллельно. найти сопротивление соединения. 2. определить время падения камня на поверхность земли с высоты h.

Показать ответ
Ответ:
Шамшербек
Шамшербек
14.08.2020 01:51
1. \frac1R=\frac1{R_1}+\frac1{R_2}+\frac1{R_3}, откуда 
R=\frac1{\frac1{R_1}+\frac1{R_2}+\frac1{R_3}}

Программа:

var R1, R2, R3, R: real;
begin
write('Введите сопротивления R1, R2, R3 (в Ом): ');
read(R1, R2, R3);
R := 1 / (1 / R1 + 1 / R2 + 1 / R3);
writeln('Полное сопротивление цепи ', R:0:3, ' Ом');
end.

2. h=\frac{gt^2}2, откуда
t=\sqrt{\frac{2h}g}

Программа:

const g = 9.8;
var h, t: real;
begin
writeln('Введите высоту h (в м): ');
read(h);
t := sqrt(2 * h / g);
writeln('Время падения ', t : 0 : 3, ' с');
end.

Блок-схемы в приложении:
Составить блок-схему и написать программу на языке pascalabc.net. 1. три сопротивления r1, r2, r3 со
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота