В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Пулmn
Пулmn
29.04.2022 07:09 •  Информатика

Составить блок схему и написать программу на языке с++. с цикла определите является ли сумма цифр введенного натурального числа четной или нечетной.

Показать ответ
Ответ:
bekarys3
bekarys3
08.10.2020 22:04

#include <iostream>

int main() {

   std::string s;

   int S = 0;

   std::cin >> s;

   for (int i=0; i<s.length(); i++){

       S += int(s[i]-'0');

   }

   std::cout<<(S%2?"Odd":"Even");

   return 0;

}

Объяснение:


Составить блок схему и написать программу на языке с++. с цикла определите является ли сумма цифр вв
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота