В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
korolev98
korolev98
28.02.2020 14:21 •  Информатика

Составить блок-схему и написать программу в эвм вводятся по очереди координаты n точек. определить, сколько из них попадает в круг радиусом r с центром в точке (a,b).

Показать ответ
Ответ:
BandaMin
BandaMin
08.10.2020 02:51
Блок-схема - в прилагаемом файле.
Программа:
var n,r,a,b,k,x,y,i:integer;
begin
readln(n,r,a,b);
k:=0;
for i:=1 to n do
 begin
 readln(x,y);
 if sqr(x-a)+sqr(y-b)<r*r then k:=k+1;
 end;
writeln('k = ',k);
end.

Пример:
3 4 1 1
2 2
-2 -3
0 0
k = 2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота