В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
vNeronRazerv
vNeronRazerv
12.12.2022 12:20 •  Информатика

Составить блок-схему и написать программу ввода с клавиатуры числа и проверить отрицательное ли оно или оканчивается на 3.

Показать ответ
Ответ:
Rashid200413
Rashid200413
21.04.2022 02:29
Var
i,j,k:longint;
    begin
         for i:=1 to 1000 do
              for j:=1 to 1000 do       
                   for k:=1 to 10000 do             
                      if sqr(i)+sqr(j)=sqr(K)then               
                           begin                 
                                writeln(i,' ',j,' ',k);  {вывожу все тройки, можно убрать}             
                                     if i+j+k=1000 then                 
                                          begin                 
                                               writeln('! ',i,' ',j,' ',k);  {нужная тройка}                
                                                exit; {прерывание программы}                
                                          end;               
                           end;   
     end.


Существуют тройки пифагора, то есть a^2+b^2=c^2 . есть лишь одна такая тройка, что a+b+c=1000 . напи
0,0(0 оценок)
Ответ:
Рома3762378433
Рома3762378433
13.07.2022 17:16
program cube; var a : real; begin writeln('Программа вычисляет объем куба и площадь '+ 'его боковой поверхности по длине ребра'); {I - ввод + ЗОД} repeat write('Введите длину ребра куба '); readln(a); if a<=0 then writeln('Ошибка! Длина ребра не может быть нулевой или отрицательной. '+ 'Повторите ввод.'); until a>0; {II, III - расчет и вывод} writeln('Длина ребра куба = ',a:8:3,' м'); writeln('Объем этого куба = ', (a*a*a):8:3,' м^3'); writeln('А площадь его боковой поверхности = ', (6*a*a):8:3,' м^2'); writeln('Нажмите [Enter] для завершения программы'); readln; end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота