В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
PolinaFox6002
PolinaFox6002
19.06.2022 21:42 •  Информатика

составить код в Python 1) Определите по номеру года, является или нет этот год високосным. Указание: год считается високосным, если номер этого года делится нацело на 4, за исключением тех, которые делятся нацело на 100 и не делятся на 400.
2)Составить программу определения наибольшего общего делителя двух неотрицательных чисел НОД (a, b) по алгоритму Евклида. Если a=b, то НОД (a, b) = a или НОД (a, b) = b, иначе, если a>b, то НОД (a, b) = НОД (a–b, b), иначе НОД (a, b) = НОД (a, b–a). Последнее действие выполняется до тех пор, пока a не станет равным b.
3) Составить программу, которая заставляет заданный пользователем текст мигать на экране монитора N раз. Весь предыдущий текст на экране не должен исчезать!

Показать ответ
Ответ:
artiom726
artiom726
20.05.2023 22:32

Все правила выполнения чертежей, действующие в настоящее время, отражены в государственных стандартах (ГОСТ) Единой Системы Конструкторской Документации (ЕСКД), учитывающей многие рекомендации международных организаций по стандартизации.

Все стандарты, предусмотренные ЕСКД, распределяются по следующим классификационным группам:

0 — общие положения;

1 — основные положения;

2 — классификация и обозначения изделий в конструкторских документах;

3 — общие правила выполнения чертежей;

4 — правила выполнения чертежей в машиностроении и приборостроении;

5 — правила обращения конструкторских документов (учет, хранение, дублирование, внесение изменений);

6 — правила выполнения эксплуатационной и ремонтной документации;

7 — правила выполнения схем;

8 — правила выполнения строительных документов и документов судостроения;

9 — прочие стандарты.

0,0(0 оценок)
Ответ:
Vova50915091
Vova50915091
03.02.2022 00:23

1. a = int(input())

if a < 0:

   print('Отрицательное число')

elif a = 0:

   print(' ноль ')

else:

   print(' Положительное число') .

2. i = 0

while i != 5:

   i += 1

   print('8 класс')

3. i = [1,1,1,1,1]

for a in range(5):

   print('8 класс')

Объяснение:

Надеюсь вы так работали с циклом фор,а то у учительницы глаза на лоб вылезут). Вообще вот мое объяснение:
1. Сначала в питоне пишем переменную с оператором инпут для ввода числа, потом ставим условия if и elif, это одно и тоже но elif для множества условий. else - в противном случае. И там условия.

2. Берем переменную i(ее обычно используют для циклов) и пишу я: пока i не равно 5 учитывая что i равно 0 идет пять раз. А что бы шло пять раз надо дойти до 5 добавляя +1 к переменной.

3. Range функция арифмет. прогресии. Она считает сколько элементов в массиве и это использу. для цикла в цикле пишу 8 класс.

Учите пайтон - пайтон сила. А так хорошо размялся.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота