В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
гпү
гпү
22.01.2023 21:53 •  Информатика

Составить , которую можно решить с цикла предусловия и соответственно написать программу в паскале.

Показать ответ
Ответ:
ЛизаБугакова
ЛизаБугакова
02.10.2020 13:42
Написать программу, которая выводит на экран сумму ряда
\frac{945}{9} - \frac{927}{33} + \frac{909}{507} - ...+ \frac{27}{1233}

пусть a – числитель; b – знаменатель; da и db – шаг для числителя и знаменателя; n  -  для смены знака;    
Программа:
const
da=  -18; {927-945}
db= 24;   {33-9}
var a,b,n: integer;
s: real;
     begin
         s:=0; n:=1; a:=945;b:=9;      
             while a>=27 do      
                   begin      
                         s:=s+a/b*n;    {подсчет суммы}      
                         a:=a+da;      
                         b:=b+db;      
                         n:= -1*n;        {изменение знака}        
                  end;
writeln('s=',s:4:2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота