В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
СоваИгорь
СоваИгорь
06.07.2020 00:56 •  Информатика

Составить линейную программу, печатающую значение true, если указанное высказывание является истинным, и false — в противном случае. цифры данного трехзначного числа n являются членами арифметической прогрессии. 2 составить программу с ветвлением, печатающее слово ‘да’, если указанное высказывание является истинным, и ‘нет’ — в противном случае. язык с++. надо с обьяснениями

Показать ответ
Ответ:
lenab85
lenab85
09.10.2020 22:19

#include <iostream>

#include <cstdlib>

using namespace std;

int main()

{

int number; //Вводимое число

int difference_first, difference_second; //переменные проверки арифм. прогр.

cout << "Enter three digit number: "; cin >> number; //ввод трехзначного числа

while(number < 100 or number >= 1000){

 //проверка числа на трехзначность

 cout << "Error!\nEnter three digit number: "; cin >> number;

}

 difference_first = number % 10 - (number / 10 % 10); //разница между третьей цифрой и второй

 difference_second = (number / 10 % 10) - (number / 100 % 10); // разница между второй цифрой и первой

   if(difference_first == difference_second){ // если эти разницы равны, значит

    cout << "YES!" << endl;       // вывод, ДА

   }else cout << "NO!" << endl;      // иначе, НЕТ

system("pause");

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота