В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Keeping
Keeping
22.02.2023 11:07 •  Информатика

Составить программу(10класс): дано предложение,заменить в нем все запятые на точки и удалить из предложения подстрочку по запросу пользователя.

Показать ответ
Ответ:
элллллляяяяя555
элллллляяяяя555
02.10.2020 11:55
uses Crt;
 var  Stroka, PodStroka: string;
     poz, i: integer;
begin
 ClrScr;
 Write(' Stroka :   '); ReadLn (Stroka);
 for i:= 1 to length (Stroka) do
     if Stroka[i]=',' then Stroka[i]:='.';

 WriteLn(' Zamena :   ', Stroka);
 WriteLn;
 Write(' PosStroka :   '); ReadLn (PodStroka);
 poz:=Pos(PodStroka, Stroka);
 Delete (Stroka,poz,length(PodStroka));
 WriteLn(' Udalili :   ', Stroka);
 ReadLn;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота